Discover™ Viewer 2015 User Guide

Discover Viewer is developed and supported by
Pitney Bowes Software Pty Ltd

ASIA PACIFIC / AUSTRALIA
Suite 1, Level 1, 68 Waterloo Road
Macquarie Park NSW 2113 Australia

software.support@pb.com
www.pbEncom.com

DISCOVER VIEWER RELEASE HISTORY
2015 April 2015
# Table of Contents

1 Introduction ............................................................................................. 1
   Conventions Used in this Guide ........................................................... 3
   Obtaining Help ..................................................................................... 4
   System Requirements ........................................................................ 4

2 Understanding the Discover Viewer Interface ...................................... 5
   Main Window .......................................................................................... 5
   Menus ..................................................................................................... 7
      File Menu .......................................................................................... 7
      View Menu ........................................................................................ 9
      Display Menu .................................................................................. 11
      Tools Menu ..................................................................................... 12
      Window Menu .................................................................................. 12
      Help Menu ...................................................................................... 13
   Toolbars .................................................................................................. 14
      Main Toolbar .................................................................................... 14
      Zoom Controls Toolbar .................................................................. 15
      Cursor Plane Toolbar .................................................................... 17
      Line Iterator Toolbar ...................................................................... 18
   Customizing the Interface ...................................................................... 19
      Showing and Hiding Toolbars .......................................................... 19
      Docking and Undocking Toolbars and Windows ................................ 19
      Auto-hide Windows ......................................................................... 20
      Customizing Toolbars and Window Views ....................................... 20
   Workspace Tree ...................................................................................... 21

3 Getting Started ...................................................................................... 23
   A Quick Guide to Viewing Data ............................................................. 23
   About Session Files ................................................................................ 24
      Troubleshooting Opening a Session File .......................................... 25
      Creating Session Files ..................................................................... 25

4 Navigation .............................................................................................. 27
   Page Mode ............................................................................................. 27
   Data Mode ............................................................................................. 27
   3D Mode ............................................................................................... 29
   3D Navigation Controls ......................................................................... 30
   Using the 3DConnexion SpaceNavigator™ .......................................... 33
   3D Display Modes ................................................................................ 34
Normal View Mode ................................................................. 35
Page Layout Mode ................................................................. 35
Full Screen Mode ................................................................. 35
3D Stereo Visualization ......................................................... 36
  HDMI 3D ............................................................................. 36
  Dual Projectors ................................................................. 37
  Anaglyph Mode ................................................................. 38
Saving and Restoring Views .................................................... 38
3D Cursor Plane ................................................................. 38
  Controlling the Cursor Plane Display ..................................... 39
  Controlling the Cursor Plane Position and Orientation ................ 40
  Navigating on the Cursor Plane ............................................. 40
  Changing Cursor Plane Properties ......................................... 41
    Plane ................................................................................ 41
    Appearance ......................................................................... 44
Survey Line Navigation ........................................................... 45
Line Iterator Tool ................................................................. 45

5 Controlling the Display Window ........................................... 47

  Working with the Workspace Tree ........................................... 47
  Display Types ........................................................................ 49
  Object Types ......................................................................... 50
  Hide and Show Objects ......................................................... 51
  Configure Axis ....................................................................... 52
  Change Scale and Axis Exaggeration ..................................... 52
  Change Lighting .................................................................... 54
  Display a Floating Colour Bar ............................................... 55
  Change Background Colour .................................................... 57
  Display a Sky Map ............................................................... 57

6 Interrogating Objects .......................................................... 59

  Distance and Bearing Tool ................................................... 59
  Interrogating Objects ............................................................ 59
  Interrogating Features .......................................................... 60
  Clipping ................................................................................. 60

7 Output and Printing ............................................................ 61

  Page Layout Mode ............................................................... 61
    Customizing the Page Layout ............................................... 62
    Add a Title .......................................................................... 63
    Borders, Background, and Margins ....................................... 64
    Capturing the View as an Image ............................................ 65
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Printing</td>
<td>66</td>
</tr>
<tr>
<td>Default and Offline Printer Configuration</td>
<td>67</td>
</tr>
<tr>
<td>8 Customizing Discover Viewer</td>
<td>69</td>
</tr>
<tr>
<td>Customizing Interface Settings</td>
<td>69</td>
</tr>
<tr>
<td>File Tab</td>
<td>70</td>
</tr>
<tr>
<td>Size Tab</td>
<td>71</td>
</tr>
<tr>
<td>View Tab</td>
<td>72</td>
</tr>
<tr>
<td>File Locations Tab</td>
<td>73</td>
</tr>
<tr>
<td>Page Setup Tab</td>
<td>74</td>
</tr>
<tr>
<td>Full Screen Tab</td>
<td>75</td>
</tr>
<tr>
<td>Customizing Toolbars</td>
<td>75</td>
</tr>
<tr>
<td>Adding and Removing Tools</td>
<td>76</td>
</tr>
<tr>
<td>Restoring Toolbar Settings</td>
<td>76</td>
</tr>
<tr>
<td>Toolbar Button Size</td>
<td>76</td>
</tr>
<tr>
<td>Show and Hide Tool Labels</td>
<td>77</td>
</tr>
<tr>
<td>Creating New Toolbars</td>
<td>77</td>
</tr>
<tr>
<td>Other Customizations</td>
<td>77</td>
</tr>
<tr>
<td>Assigning Custom Keyboard Shortcuts</td>
<td>77</td>
</tr>
<tr>
<td>Appendices</td>
<td>79</td>
</tr>
<tr>
<td>A 3D Cursor Keyboard Shortcuts</td>
<td>81</td>
</tr>
<tr>
<td>Index</td>
<td>83</td>
</tr>
</tbody>
</table>
Discover Viewer is a stand-alone, free-to-distribute visualizer for Discover 3D and Discover PA session files (.EGS). The types of data that can be handled by Discover session files and visualized with Discover Viewer include:

- Gridded surfaces representing topography, geochemistry and geophysics
- Drillholes containing assays or lithological data
- 3D DXFs, grids and raster images
- Point and line data
- Block/voxel models
- 3D wireframe models and surfaces
- Profiles and sections
- Scattergrams and graphs
- Flight paths
Discover Viewer enables data to be viewed interactively with zooming, panning and fly-through capability controlled by either a regular mouse or the intuitive SpaceNavigator 3D mouse. 2D and 3D views can be captured as images and displayed in a layout for presentation purposes, or used in other applications, such as PowerPoint.

Discover Viewer operates seamlessly with both Discover 3D and Discover PA session files. No additional project specification or data setup is required—the data and display settings created by these products are passed directly to Discover Viewer.
Conventions Used in this Guide

Certain conventions are used throughout this guide.

- Keys on the keyboard appear in small capital letters. For example, the Ctrl key appears as CTRL in the text.

- Menu options and dialog items are in boldface. For example, choose File>Open Session.

- Buttons to be clicked are in boldface. For example, click the Show Cursor Plane button.

- References to other sections in the documentation in italic. For example, see the Display 3D Surfaces chapter.
Obtaining Help

The Help menu provides access to the Discover Viewer Help, User Guide (PDF), and About commands. The Help is an interactive version of the User Guide.

System Requirements

Discover Viewer is supported on Windows 7 and 8 (32-bit and 64-bit) operating systems but not on earlier Windows systems.

Minimum requirements

- Pentium 4 series or equivalent CPU processor
- 2 gigabyte of RAM memory
- Dedicated graphics card that supports OpenGL 3.0, such as Nvidia, ATI or Matrox models (note that Intel integrated graphics is not supported).
- A monitor of at least XGA capability (1024 x 768 resolution)

Recommended requirements

- Core 2 series or equivalent CPU processor (note that Discover Viewer does not utilise multiple CPU cores)
- 4 gigabytes of RAM memory
- Dedicated graphics card with 256 MB dedicated VRAM memory, and with OpenGL optimized drivers, such as Nvidia Quadro or ATI FireGL series.
- A monitor of at least SXGA capability (1280 x 1024 resolution)
2 Understanding the Discover Viewer Interface

- Main Window
- Menus
- Toolbars
- Customizing the Interface
- Workspace Tree

Main Window

Discover Viewer window

The Discover Viewer window comprises the followings regions:
• The Display Window is the main region for displaying data in a range of views. These can include Profiles, 2D and Flight Path Maps, 3D Maps, Decay Curves, and a variety of Graphs types.

• The Workspace Tree (see Workspace Tree) provides a hierarchical view and the controls for data views in the Display Window. This window can be hidden and shown from the Main toolbar or the View menu. It can also be dragged (floated) into any position or docked into the window frame.

• The Toolbars contain commonly used tools are grouped by function. The toolbars can be dragged (floated) into any position or docked into the window frame. The toolbars can be hidden and shown from the Toolbars submenu on the View menu. For more information about the tools available, see Toolbars.

• The Main menu, normally found at the top of the window frame, can be dragged into any position. It contains the following menus:
  
  • File menu: Control the opening of session files, exporting imagery, and printing.
  
  • View menu: Options to view/hide Information Windows, Toolbars, view modes, and status bar.
  
  • Display menu: Add axes, sky maps and legends to a 3D window.
  
  • Window menu: Control of the position and selection of window.
  
  • Tools menu: Additional tools for customizing the viewer and the Grid Flipper.
  
  • Help menu: Help and reference material.

  For more information, see Menus.

• A Status Bar at the base of the window frame displays navigation and cursor coordinates bearing and inclination information and tool tips. This window can be hidden and shown from the View menu.

• The Feature Data Window dynamically displays information about features selected in the Display Window. This window can be hidden and shown from the Main toolbar or the View menu. It can also be dragged (floated) into any position or docked into the window frame.
- The **Data Manager** window by default appears beneath the Workspace Tree, which is is used to display and manage data objects open in a session file. The Data Manager can be removed from view and restored using the option in the Toolbars shortcut menu.

- The **Data Window** dynamically displays information about objects selected in the Display Window. This window can be hidden and shown from the Main toolbar or the View menu. It can also be dragged (floated) into any position or docked into the window frame.

### Menus

- **File Menu**
- **View Menu**
- **Display Menu**
- **Tools Menu**
- **Window Menu**
- **Help Menu**

### File Menu

- Open Session...
- Close All
- Save View As...
- Print... Ctrl+P
- Print Setup...
- Page Setup...
- 1 explorationexample2
- 2 west wyalong all displays
- 3 infrastructureexample1
- Exit
File>Open Session

Open a Discover 3D or Discover PA session file (.EGS). For more information about session files, see About Session Files.

Note

Only session files created in Discover 3D 2014 and Discover PA 2015 can be opened in Discover Viewer 2015.

File>Close All

Close all open datasets in Discover Viewer.

File>Save View As

Save current Display Window contents into an image file for presentation purposes. Includes controls for image resolution and format.

File>Print

Print the current Display Window to the selected printer or print driver.

File>Print Setup

Display and set printer properties.

File>Page Setup

Define page size for hardcopy prints and page size for the page layout mode.

File>sessions

The names of the last five session files saved while using Discover Viewer are displayed in the File menu list. These files can be individually selected to quickly access previously saved sessions.

File>Exit

Close the session and exit Discover Viewer.
View Menu

<table>
<thead>
<tr>
<th>Toolbars</th>
<th>Main</th>
</tr>
</thead>
<tbody>
<tr>
<td>Appearance</td>
<td>Documents</td>
</tr>
<tr>
<td>Workspace</td>
<td>Objects</td>
</tr>
<tr>
<td>Data Manager</td>
<td>Data Objects</td>
</tr>
<tr>
<td>Data window</td>
<td>Zoom Controls</td>
</tr>
<tr>
<td>Feature Spreadsheet</td>
<td>Line Iterator</td>
</tr>
<tr>
<td>Status Bar</td>
<td>Features</td>
</tr>
<tr>
<td></td>
<td>Feature Editing</td>
</tr>
<tr>
<td></td>
<td>Decay Curves</td>
</tr>
<tr>
<td></td>
<td>Cursor Plane</td>
</tr>
<tr>
<td></td>
<td>Reset Arrangement</td>
</tr>
<tr>
<td></td>
<td>Save Arrangement</td>
</tr>
<tr>
<td></td>
<td>Restore Arrangement</td>
</tr>
</tbody>
</table>

**View>Fit to Page**

Resets the frame boundary in Page Layout mode to the extents of the page.

**View>Normal**

Put the Display Window in normal mode for navigating, digitizing and analysis. See *Normal View Mode*. 
View>Page Layout
Put the Display Window in page layout mode for hardcopy printouts and export. See *Page Layout Mode*.

View>Actual Size
Put the Display Window in page layout mode at the actual page size.

View>Full Screen
Display the Display Window in full screen mode.

View>3D Stereo
Open the 3D Stereo wizard.

View>Toolbars>toolbar
Hide or show toolbars.

View>Toolbars>Reset Arrangement
Restore toolbar and window placement to factory settings.

View>Toolbars>Save Arrangement
Save toolbar and window placement, which can be restored in subsequent Discover Viewer sessions.

View>Toolbars>Restore Arrangement
Restore toolbar and information window placement to last saved arrangement settings.

View>Appearance
Select skin to display Discover Viewer.

View>Workspace
Hide or show the Workspace Tree window.

View>Data Manager
Hide or show the Data Manager window.
Discover Viewer allows various external objects to be added to an existing 3D Display Window.

Display>Axis
Add additional Axis layer to the Workspace Tree. For more information, seeConfigure Axis.

Display>Sky Map
Add a Sky Map image layer to the Workspace Tree to display a photo-realistic sky view backdrop to your 3D environment. For more information, see Display a Sky Map.

Display>Floating Colour Bar
Displays a colour bar (i.e. legend) for any open drillhole project, grid surface or voxel model. For more information, see Display a Floating Colour Bar.
Tools Menu

Tools>Options
Display and edit default settings for Discover Viewer.

Tools>Grid Flipper
Open Grid Flipper to quickly toggle between grids surfaces with a single surface layer.

Tools>3D View Manager
Open 3D View Manager to save and restore 3D views.

Tools>NotePad
Open Windows Notepad.

Tools>Windows Calculator
Open Windows Calculator.

Window Menu
The Window menu controls the various window displays that may be presented on the screen at any time.
Window>New Window

Creates a new document window.

Window>Cascade

Windows are arranged on the screen with uniform size and with overlap from the top left corner of the Discover Viewer display area.

Window>Tile

Windows are arranged with equal area and no overlap in the Discover Viewer display area.

Window>Arrange Icons

Arranges minimised window icons at the base of the Discover Viewer display area.

Window>Split

Enables a display such as a Spreadsheet to be split and resized.

Window>windows

The Discover Viewer displays a list of all the available windows, included those that have been minimised. You can use the cursor to point to one of these windows to activate it (bring to the front of overlapping displays). The name used in the Window list is that shown in the window’s title bar.

Help Menu

Help>Help Topics

View Discover Viewer interactive help topics.

Help>User Guide

Open Discover Viewer User Guide documentation (PDF format).
Help>About Discover Viewer

Display information about the installed version of Discover Viewer.

Toolbars

Discover Viewer toolbars are fully customisable and can be displayed in either docked or floating mode.

• **Main Toolbar**: commonly used tools.
• **Zoom Controls Toolbar**: navigational tools.
• **Cursor Plane Toolbar**: tools for clipping the 3D view.
• **Line Iterator Toolbar**: graph and profile line iteration tool.

**Note**
A brief description of the toolbar tool is displayed when hovering the mouse over a tool button. Alternatively, a description of the tool is displayed in the Status Bar.

For information on arranging and customizing toolbars, see:

• **Showing and Hiding Toolbars**
• **Docking and Undocking Toolbars and Windows**
• **Customizing Toolbars and Window Views**
• **Customizing Toolbars**

**Main Toolbar**

![Main Toolbar Image]

**Open Session** – Open a Discover 3D or Discover PA session file (.EGS).
**Undo/Redo** – Undo or redo the last change committed in the Display Window.

**Show 3D Properties** – Display properties of 3D Map, Axis, and Cursor Plane.

**Background colour** – Modify the default background colour in the 3D Display Window.

**Normal View/Page Layout** – Toggle the Display Window between Normal and Page Layout views. The Normal view is used to perform most navigational tasks in 3D. The Page Layout view is used for presentation of hardcopy outputs; however, standard navigational tasks can also be performed in this mode.

**Distance/Bearing Measuring Tool** – Measure distance, bearing, inclination and total distance for objects on the Cursor plane.

**Workspace Tree** – Display or hide the Workspace Tree.

**Data Window** – Display or hide the Data Window which interactively displays data from the following object types; Drillholes, Lines, Directional Vectors and Points.

**Feature Data Window** – Display or hide the Feature Data Window which displays interactive information contained in a Feature Database.

**Zoom Controls Toolbar**

The Zoom Toolbar controls navigation, zooming and custom view management in the Display Window. The controls available depend on the selected display:

**All displays**

See *Page Mode*.

**Select** – Use this control for selecting objects. Refer to *Interrogating Objects* for instructions.

**Zoom Page in Place** – ????.
Zoom in, Zoom out – The zoom controls either zoom in or out in the Display Window, holding the Shift key will perform the opposite zoom function. With either the Zoom in or Zoom out control activated, when the left mouse button is held down and the mouse cursor is dragged, the Display Window will zoom in or out to the specified zoom field.

Pan – The Pan control enables panning in the Display Window.

Fit to Page – Resizes the page to fit to the extents of the view.

3D displays

See 3D Mode.

3D Navigation – This is the primary 3D Navigation control. Refer to Navigation for instructions.

Reset View – Reset 3D View restores the 3D Display Window so objects are centred and displayed within the window.

3D View Manager – The 3D View Manager allows the user to save custom views within the 3D Display Window. See Saving and Restoring Views.

Change View Direction – Rotate view direction of the 3D Display Window to the specified direction (North, South, East, West, Up and Down). For example, selecting Look North orientates the view to be looking to the north.

Perspective/Orthographic – 3D display modes

- Perspective – Objects that are further away from the viewer are scaled so they appear smaller than closer objects. Perspective view provides more information about depth and is often easier to work with because it simulates the real life view.

- Orthographic – A form of parallel projection (also known as an isometric or axonometric projection) where identically sized objects are displayed with the same size regardless of the distance they are positioned from the viewer. Orthographic view is best used when it is important to be able to judge proportion and size, such as when measuring distances.

2D displays (profiles, graphs, 2D maps)

See Data Mode.
Data Zoom In and Out – The zoom controls either zoom in or out in the frame, holding the Shift key will perform the opposite zoom function. With either the Zoom in or Zoom out control activated, when the left mouse button is held down and the mouse cursor is dragged, the Display Window will zoom in or out to the specified zoom field.

Data Pan – Enables panning in the Display Window.

Data Fit – Resizes the view to fit to the extents of the frame.

Cursor Plane Toolbar

The Cursor plane toolbar contains tools required for the operation of the Cursor plane. The Cursor plane is used as a clipping plane to hide or obscure object data.

Show Cursor plane – The Show Cursor plane option displays or hides the Cursor plane.

Lock Cursor plane – Disables all Cursor plane movement controlled by the keyboard shortcuts, preventing the Cursor plane from being accidentally moved. This feature locks the Cursor plane origin X, Y and Z coordinate.

Cursor plane orientation – Toggles the Cursor plane orientation around the X, Y and Z axes.

Bond – Bonds the Cursor plane to a selected georeferenced image or dataset (e.g. drillholes) in the Workspace Tree. This feature is auto-enabled when interrogating data.

Plane clipping – Plane clipping hides all 3D data objects in front of the Cursor plane. This is useful when a slice view is required of the 3D datasets.

Defined clipping – Enables the supplementary clipping of a 3D dataset as defined by the current position of the Cursor plane. This option enables the current position of the Cursor plane to temporarily clip the 3D dataset whilst being able to move the Cursor plane to another position. This is useful to reveal obscured features.
**Perpendicular** – This will orientate the view direction perpendicular to the Cursor plane.

**Shrink, Enlarge and Fit Cursor plane** – The Shrink, Enlarge and Fit Cursor plane controls resize the Focus Box. The Focus Box is the bounding extents of the Cursor plane.

**Cursor Plane Properties** – Global properties for appearance and Cursor plane behaviour can be modified on the Cursor Plane Properties dialog.

**Line Iterator Toolbar**

**Select Active** – Select an Active Line from a loaded database.

**Backwards** – Moves a Graph or Profile display backwards one line in a loaded database.

**Forwards** – Moves a Graph or Profile display forwards one line in a loaded database.

**Reverse** – Reverses the direction of the line shown in a Graph or Profile display.

**Properties** – Displays the Line Iterator Properties dialog.

Customizing the Interface

Discover Viewer can be customized to suit the requirements of each individual to improve the user experience.

- **Showing and Hiding Toolbars**
- **Docking and Undocking Toolbars and Windows**
- **Auto-hide Windows**
- **Customizing Toolbars and Window Views**

Other customizations can be found in *Customizing Discover Viewer*.

**Showing and Hiding Toolbars**

To show or hide a toolbar, navigate to **View>Toolbars** and select the toolbar. Alternatively, right-click in the Main menu bar to display the toolbar shortcut menu.

**Docking and Undocking Toolbars and Windows**

The toolbars are dockable and can be freely dragged around the Discover Viewer application and displayed as either docked or floating.

The Information Windows and Workspace Tree can be displayed as docked or floating windows. To dock these windows around the display window click and hold down the left mouse button in the title bar region for any of the windows. When the window is moved, a series of docking indicators will appear in the display window. To dock the window, simply hover the mouse over one of the docking indicators and release the mouse button.

Alternatively, the window can be dragged and placed into an appropriate location as a floating window. The positions of these windows will be save upon exiting Discover Viewer.
Discover Viewer with window docking indicators.

**Auto-hide Windows**

- Located on the Information Windows and Workspace Tree is an Auto-hide control. Instead of displaying the windows as either floating or docked the windows can be temporarily hidden and displayed when the mouse cursor is hovered over. To enable or disable the auto-hide function, click the Auto-hide control (pincushion).

**Customizing Toolbars and Window Views**

To control the display of Toolbars and Information Windows, right click in the toolbar region to display a list of items. Click the item to display or hide.

Click Customize on this shortcut menu to customize individual menus and toolbars (see Customizing Toolbars).
Located on the right of every toolbar is a dropdown control which enables the customization of each toolbar. Left mouse click to access this option and select tools to display or hide.

**Workspace Tree**

The Workspace Tree lists and controls all components of the various Frames or 3D Map displays open in a session. These components may be graphical objects, drillholes, images, voxel/block models, profiles, axes, annotations etc. Each component is represented by a branch on the Workspace tree. The relationships between the branched objects are shown in the Workspace tree as a hierarchy.

Each branch in the **Workspace Tree** has a visibility check box. To turn off the visibility of a branch, in the 3D display window, uncheck the visibility box. Turning off a branch will also turn off the visibility of any sub-branches.

To the left of each subordinate branch is a + or - control. These controls indicate lower levels exist for that branch. By clicking on these boxes you can expand or collapse the object contents.

For more information, see *Controlling the Display Window.*
3 Getting Started

In this section:

- A Quick Guide to Viewing Data
- About Session Files

A Quick Guide to Viewing Data

If you are new to Discover Viewer, the following steps will guide you through the essential sections of this User Guide to quickly get you displaying and visualizing your data in the Discover Viewer environment.

Loading Session Files

Discover Viewer supports Discover 3D 2014 and Discover PA 2015 session files. Session files created with earlier versions of these products are not supported.

A session file contains the path names and display settings for a package of 2D or 3D data. It does not contain any data. Each session file has an associated set of data that Discover Viewer loads using the information stored in the session file. You need the session file and all the associated data files to visualize the complete data set.

Note

You can only view data in Discover Viewer from a Discover 3D or Discover PA session file. The data cannot be loaded directly into the viewer. For more information about session files, see About Session Files.

To open a session file in Discover Viewer, you can either:

- On the File menu, click Open Session.
- Click the  Open Session button on the main toolbar.
- Drag-and-drop the .EGS file into the viewer window.

Navigation

For 2D maps, profiles and graph frames, use the toolbar Zoom and Pan controls and the Data Zoom controls (see Zoom Controls Toolbar) to move around the views.
For 3D displays, use the on-screen navigation controls to zoom, rotate and navigate around and explore the spatial relationships between your data (see 3D Navigation Controls). Perhaps toggle the Orthographic View mode to remove the distance bias associated with the default Perspective View.

The Cursor Plane allows you to view a portion of your data in a 3D view (clipping the data view)—for example, only the data behind the cursor plane, or a preset distance either side the cursor plane (envelope). See 3D Cursor Plane for instructions.

See Navigation for more instructions on how to use the navigation controls.

Modifying the Display

You can selectively hide and show objects, change the background colour, change the scaling and axis exaggeration, change light source and shading, and other display options. See Controlling the Display Window for instructions.

Interrogating Data

The attributes of points, lines, drillholes, and feature databases can be examined dynamically. The dataset needs to be set as both Selectable and Browsable in the Workspace Tree. Move the cursor over the object to display its attributes in the Data Window (or Feature Data Window for feature databases).

Producing Output from Discover Viewer

The display window can be output with a range of options:

- In Page Layout Mode, you can use the standard printing controls to produce hardcopy of the display window. The standard navigation controls all still function in this mode.

- The display window can also be saved as an image at a user-specified resolution using the File>Save View As menu option.

About Session Files

Each session file (.EGS) has an associated set of data that Discover Viewer loads using the information stored in the session file. You need the session file and all the associated data files to visualize the complete data set. The session file is in binary format and cannot be edited.

Session files do not contain data—only the path names to the data and the display settings are stored in the session file.
• **Troubleshooting Opening a Session File**

• **Creating Session Files**

**Troubleshooting Opening a Session File**

*Note* Discover Viewer 2015 can only open a Discover 3D 2014 or Discover PA 2015 session files.

If the data files referenced by the session file are not available, Discover Viewer will not be able to load the session completely. A message is displayed when data files cannot be found or opened.

When prompted, you can either browse to locate the file, or, if the requested file is not available, click the **Cancel** button. The session will continue to load the available files.

**Creating Session Files**

When creating a session file in Discover 3D or Discover PA, use the **File>Save to Package** menu option. All datasets in the session are copied into a single folder with the .EGS session file. The file paths are relative. This folder can then be zipped and emailed for viewing on another computer with Discover Viewer.

*Note* Discover Viewer cannot create or save session files.
Discover Viewer supports a number of different navigation methods and devices.

- **Page Mode**
- **Data Mode**
- **3D Mode**
- **3D Navigation Controls**
- **Using the 3DConnexion SpaceNavigator™**
- **3D Display Modes**
- **Saving and Restoring Views**
- **3D Cursor Plane**
- **Survey Line Navigation**

**Page Mode**

Page mode enables you to see how objects are positioned on a printed page.

Page mode zooming increases the zoomed area as if magnifying the paper on which it is presented. This means that text, data, line thickness etc are all increased in size.

For a description of each button, refer to *Zoom Controls Toolbar*.

**Data Mode**

Data mode controls the data content displayed in a window, rather than the view. The data content can be zoomed, roamed and fitted similarly to Page Mode, but the content is displayed with axes etc for relative assessment.
When zooming in Data mode, a greyed rectangle over the zoomed area is drawn to provide an indication of the area to be zoomed. Resultant zooming does not affect the size of annotation or line thicknesses but acts only to increase the level of data seen in a display. Smooth scrolling of data in profiles is available to allow panning and roaming of data, especially in profiles (see below).

Smooth scrolling of profiles and maps uses the third button or depressed scroll wheel of recent mouse device types. To initiate the smooth scrolling of a map or profile, zoom to a portion of the profile or map window using the Data Zoom button.

With the profile in Data Pan mode (click button), press the third button (or scroll wheel) on the mouse and move the cursor horizontally in the window. The map or profile then moves smoothly left or right.

You may notice that as a profile scrolls, it automatically adjusts the vertical scaling to accommodate the changing data range. To have fixed scaling, display the properties of the Profile dialog, select the Y Axis Properties Tab and set the Y Axis Range and Scaling to be Fixed. The velocity of panning is proportional to the distance from the initial mouse placement.
At certain branches of the Workspace tree, a variation of the above option is provided in the context menu. This item **Data Zoom to Extents**, causes any zoomed view of a map to be displayed as a Zoom Fit. This option operates identically to the **Data Zoom Fit** button.

### 3D Mode

There are two 3D navigation modes, which can be selected from the Zoom Controls toolbar:

**3D Navigate**—This is the primary navigation control and provides the most precise control in 3D. When selected, the 3D Navigation tool is displayed in the top-right corner of the Display Window. See **3D Navigation Controls** for details.

**Select/Navigate**—Use this mode to interrogate objects in the 3D environment. See **Interrogating Objects** for more information about displaying the attributes of objects in the Display Window. When selected, position the cursor inside the Display Window, then hold the left mouse button down and drag the cursor to rotate pivot the view about the centre of the display. You can use the other controls on the **Zoom Controls Toolbar** (Zoom In, Zoom Out, Pan, Change View Direction, and such) in conjunction with the Select/Navigate tool.
3D Navigation Controls

To navigate in 3D, click the **3D Navigation** button on the Zoom Controls toolbar.

All 3D navigation is orientated about the view point. The view point is the black cube at the intersection of the XYZ axis lines that appears when clicking in the Display Window.

![The 3D navigation view point](image)

The 3D Navigation tool is displayed in the top-right corner of the Display Window. This tool fades when there is no movement after approximately 5 seconds. To redisplay, move the cursor into the top-right corner. This tool controls the eye position and the view point (the rotation point). Similar (and some additional) functions can also be performed by combinations of mouse button and keyboard keys, as described below.

![The 3D navigation tool is displayed in 3D Navigation mode.](image)

The X, Y and Z coordinates of the view point and the bearing and inclination of the view direction (from the eye position) are displayed in the Status Bar.
### Movement Using the 3D Navigation Tool

<table>
<thead>
<tr>
<th>Movement</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Zoom in and out</strong></td>
<td><strong>Zoom</strong>: Zooms in and out from the view point.</td>
</tr>
<tr>
<td></td>
<td><strong>Mouse/Keyboard</strong>: Hold down the right mouse button with the cursor positioned above (to zoom in) or below (to zoom out) the view point. Alternatively, roll the mouse wheel.</td>
</tr>
<tr>
<td><strong>Free rotate around view point</strong>:</td>
<td><strong>Hold down the left mouse button. The view will rotate freely as if you are pressing on a basketball: whichever side of the view point you click, the view will rotate away in that direction.</strong></td>
</tr>
<tr>
<td><strong>Free rotate around eye point</strong>:</td>
<td><strong>Hold down the CTRL key and the left mouse button. The view rotates in the direction of the cursor about the current eye position.</strong></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Utility</th>
<th>Diagram</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Zoom</strong>:</td>
<td>![Zoom Image]</td>
</tr>
<tr>
<td><strong>Z-rotate</strong>:</td>
<td>![Z-rotate Image]</td>
</tr>
<tr>
<td><strong>Free rotate around view point</strong></td>
<td>![Free rotate Image]</td>
</tr>
<tr>
<td><strong>Free rotate around eye point</strong></td>
<td>![Free rotate Image]</td>
</tr>
<tr>
<td>Movement</td>
<td>Using the 3D Navigation Tool</td>
</tr>
<tr>
<td>----------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>Vertical pan</td>
<td><img src="vertical_pan.png" alt="Diagram" /></td>
</tr>
<tr>
<td></td>
<td><img src="vertical_pan.png" alt="Diagram" /></td>
</tr>
<tr>
<td>Horizontal pan</td>
<td><img src="horizontal_pan.png" alt="Diagram" /></td>
</tr>
<tr>
<td></td>
<td><img src="horizontal_pan.png" alt="Diagram" /></td>
</tr>
<tr>
<td>Speed/sensitivity</td>
<td><img src="speed_sensitivity.png" alt="Diagram" /></td>
</tr>
<tr>
<td></td>
<td><img src="speed_sensitivity.png" alt="Diagram" /></td>
</tr>
<tr>
<td></td>
<td><img src="speed_sensitivity.png" alt="Diagram" /></td>
</tr>
</tbody>
</table>

The **Reset 3D View**, **View Manager** and **Change View Direction** can also be used when in 3D Navigation mode (see **Zoom Controls Toolbar**). See **Appendix A: 3D Cursor Keyboard Shortcuts** for a complete list of keyboard shortcuts.
Using the 3DConnexion SpaceNavigator™

Discover Viewer supports 3D navigation using the 3DConnexion SpaceNavigator™ device. With this device, both the eye position and view point can be moved simultaneously. This results in easy and intuitive “fly-through” style movement.

To use a SpaceNavigator device:

1. Install the 3D Connexion driver software, and upgrade to the latest version.

2. Connect the device via a USB port.

3. Start Discover Viewer. Select the Tools>Options menu option, and go to the View tab. Select the Enable 3D Connexion devices option.


The following SpaceNavigator™ controls are supported in Discover Viewer:

<table>
<thead>
<tr>
<th>Action</th>
<th>Device</th>
<th>Movement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Push/Pull</td>
<td></td>
<td>Move eye and view points forwards and backwards.</td>
</tr>
<tr>
<td>Slide</td>
<td></td>
<td>Move eye and view points to the left and right.</td>
</tr>
</tbody>
</table>
### 3D Display Modes

The Display Window can be configured to operate using several view modes. The following view modes are available:

- **Normal View Mode**
- **Page Layout Mode**
- **Full Screen Mode**
- **3D Stereo Visualization**
Normal View Mode

View>Normal

In normal mode, the Display Window is maximized to fill the extents of the window frame.

Page Layout Mode

View>Page Layout

Page Layout mode enables you to see how objects are positioned on a printed page. This view can be used to modify the size and positioning of the 3D frame border, page margins and colour legend objects prior to printing. The size and orientation of the default page is defined by the printer settings specified with the File>Page Setup tool.

Full Screen Mode

Discover Viewer can be switched into full screen mode, where the Map window will display full screen on the monitor that the window is currently positioned on.

To switch to full screen mode:

• Select View>Full Screen or select the toolbar button .

In this mode, the toolbars, status bar and workspace tree will be hidden. However by default the menu bar will remain. To re-enable controls such as the workspace tree, while in full screen mode, right-click on the menu toolbar and select the option.

To enable the 3D Navigation mode and button pad, Right click in the fullscreen map window and select the option.

To exit full screen mode:

• Locate the Close Full Screen floating toolbar button, or press Esc on the keyboard.

Additional options for fullscreen mode are available from Tools>Options>Fullscreen.
3D Stereo Visualization

Discover Viewer is capable of displaying full colour 3D stereo projection systems to create a semi immersive 3D visualization environment. The use of full colour 3D stereo visualization is quickly becoming the preferred way for geoscientists to communicate and collaborate with each other. It allows the user to analyses and detect very subtle geometric relationships that are often overlooked in conventional 3D views. It is also a powerful presentation tool to display fly-through animations.

Discover Viewer supports three methods of stereo visualization:

- **HDMI 3D**
- **Dual Projectors**
- **Anaglyph Mode**

HDMI 3D

This method will output the 3D map window to an external display connected by HDMI. The HDMI standards later than 1.4a support side-by-side viewing of 3D stereo. HDMI 3D ready devices include TVs, home theatre projectors and PC monitors. These generally are provided with Active shutter glass.

**To enable 3D stereo on an external HDMI monitor:**

1. Connect a HDMI 3D ready device to your computer, and extend the desktop to this.
2. Select View>3D Stereo or right click on the 3D Map branch in the workspace tree, and select Stereo View.
3. In the Stereo Display dialog select the HDMI 3D mode.
4. Select the 3D ready HDMI device in the 3D Display list.
5. Click OK.
6. The 3D Map will be duplicated as a side-by-side 3D stereo pair on the 3D display.

**Note**

Do not duplicate or mirror the desktop to the 3D display.
7. On your devices remote control, enable the 3D Mode and select the corresponding side-by-side mode, and wear the device's 3D glasses. Consult the device's documentation for help on doing this.

8. On your primary monitor you will be able to navigate and adjust the 3D display. It will also open a **Stereo Control** dialog. This allows adjustment of the separation (depth of view) and convergence (focus) angles. Adjust these as necessary to achieve a good display.

### Dual Projectors

This method outputs the stereo pair to two separate external display. These will be two projectors in a specialized 3D projection cage. The cage aligns the two projectors to overlay the output frames exactly. They generally also have polarized filters on the projectors, and use passive polarized glasses. This is similar to what is used in commercial movie cinemas.

**To enable 3D stereo on an dual 3D projector system:**

1. Connect the two devices device to your computer, and extend the desktop to these.

   **Note**

   Do not duplicate or mirror the desktop to the 3D display.

2. Select **View>3D Stereo** or right click on the 3D Map branch in the workspace tree, and select **Stereo View**.

3. In the Stereo Display dialog select the **Dual Projector** mode.

4. Select the two projectors in the two display lists.

5. Click **OK**.

6. The 3D Map will be duplicated as a side-by-side 3D stereo pair on the projectors.

7. Wear the projector polarized glasses to view in 3D.

8. On your primary monitor you will be able to navigate and adjust the 3D display. It will also open a **Stereo Control** dialog. This allows adjustment of the separation (depth of view) and convergence (focus) angles. Adjust these as necessary to achieve a good display.
Anaglyph Mode

This mode creates a pair of composite red and blue images in the 3D Display Window, which are slightly offset from each other. The composite anaglyph view is then visualized through a pair of red-blue glasses, which filter out the red image in the red eye and the blue image in the blue eye. The main disadvantage of anaglyph mode is that it does not allow the image to be viewed in true colour.

Saving and Restoring Views

Use the 3D View Manager to save and restore custom views in the 3D Display Window.

To open, click the the 3D View Manager button on the Zoom Controls toolbar.

Add new 3D view to the 3D View Manager.

Delete the selected 3D view from the 3D View Manager.

Display the selected 3D view from the 3D View Manager.

Display the selected 3D view from the 3D View Manager and restore the 3D data window to the select view extents and dimensions.

Rename the selected 3D view from the 3D View Manager.

3D Cursor Plane

The 3D Cursor Plane can be used as a clipping plane to hide or obscure 3D object data. This can be useful in complex datasets where a mass of drillholes obscures the data of interest. Alternatively, only a user-specified envelope or slice of data about the plane can be displayed.

Note

The Cursor Plane is not visible in Bond mode.
Cursor plane (red outline) with bounding box (green box) and, 3D Cursor crosshairs (light red).

For more information on controlling and using the cursor plane, see:

- Controlling the Cursor Plane Display
- Controlling the Cursor Plane Position and Orientation
- Navigating on the Cursor Plane
- Changing Cursor Plane Properties

**Controlling the Cursor Plane Display**

The Cursor plane toolbar contains tools required for the operation of the Cursor plane.

Press the Show Cursor Plane button to display the default Cursor Plane location surrounded by a bounding Focus Box.

Press the Cursor Plane Properties button to modify the appearance of the Cursor Plane. For more information, see Appearance section of the Cursor Plane Properties dialog.
Controlling the Cursor Plane Position and Orientation

Press the **Cursor Plane Properties** button to modify the position and orientation of the Cursor Plane. For more information, see *Plane* section of the Cursor Plane Properties dialog.

Navigating on the Cursor Plane

3D navigation and selection on the Cursor plane can be achieved using the **Select/Navigate** control. When this control is enabled a set of crosshairs will appear on the Cursor plane, the crosshairs assist in the precise selection and digitization on the Cursor plane. X, Y & Z coordinates for the crosshair position displayed are on the **Status Bar**.

The up and down keyboard arrow keys control the inclination of the Cursor plane. This can change the X, Y and Z coordinates of the plane, as the rotation is applied about the centre of the bounding box, not the current centre point of the plane.

The left and right keyboard arrow keys control the bearing of the Cursor plane. This can change the X, Y and Z coordinates of the plane, as the rotation is applied about the centre of the bounding box, not the current centre point of the plane.

The page up and page down keyboard keys move the Cursor plane laterally. The Cursor plane is kept parallel to but shifted left or right (up or down) from the current position, maintaining a fixed inclination and bearing.
Changing Cursor Plane Properties

The Cursor Plane Properties dialog is divided into two sections:

- **Plane**
- **Appearance**
Plane

The 3D position of the Cursor plane can be set manually via the Origin, Inclination and Bearing options.

The cursor plane Step Distance option controls the distance it is shifted with each PAGE UP and PAGE DOWN key press. This is an excellent way to visualize slices through a 3D dataset at uniform spacings (e.g. 100 m intervals)

The Clip option refines the operation of the Plane clipping tool. Clipping is dynamic: if the cursor is moved (e.g. dip and azimuth, or lateral movement), the clipping region will follow.

Six clipping modes are available:

• **None** - No clipping is applied, replicates having the Plane clipping option disabled.

• **Nearest** - Hides all data in front of the Cursor plane, applies the clip dynamically when the Display Window is rotated.

• **Positive** - Hides all data in front of the Cursor plane from the current view point. Data clip is maintained even when rotating the Display Window.

• **Negative** - Hides all data behind the Cursor plane from the current view point. Data clip is maintained even when rotating the Display Window.

• **Envelope** - Displays data within a defined clip envelope from the Cursor plane. For example, setting a +/-25 m envelope width will display a 50 m thick envelope (total) of data centred on the Cursor plane (i.e. 25 m either side of the Cursor plane).

• **Slice** - Displays data within a defined clip width behind the Cursor plane. For example, setting a 25m slice will display data up to 25m behind the Cursor plane.
A skarn model (vector) and drillhole dataset before (left) and after application of a 40 m wide clipping envelope centred on an inclined Cursor plane.

Dynamic clipping by using the Page Up/Down keys to shift the Cursor plane laterally whilst a clipping envelope is enabled.
Appearance

The **Appearance** section provides a range of cosmetic controls for the Cursor plane, cross hair and focus box colouring, size, style and transparency.

The **Grid** option (highlighted in the above image) allows the user to visualize a continuous square grid across the cursor plane surface, with a line spacing as set next next to the Manual option (dialog below has 50 map units set). This can help with visualizing distances and sizes.

Disabling the **Align/Attach to a series by mouse click** option prevents the Cursor plane bonding to an image.

The **Lock Bearing** and **Inclination Control** options are provided to prevent the user inadvertently altering these parameters with the keyboard arrows. When locked, the appropriate buttons will have no effect until the lock is disabled.

The **Keyboard Tips** and **Click Tips** tabs under the **Cursor Plane Properties** dialog provide a listing a keyboard shortcuts and mouse button combinations for Cursor plane control and feature editing. Refer to 3D Cursor Keyboard Shortcuts for a complete list of shortcuts.
Survey Line Navigation

You can find the line that you want to display by the following means:

- The drop-down line list available from the Line Iterator Tool.
- The forward and backwards arrow buttons on the Line Iterator Tool to scroll through the line list spatially or sequentially.
- The Flight Path Map displays traverse lines that can be selected graphically. Profiling displays, such as Profile Document windows or Decay Tools, can use this selection procedure.

Line Iterator Tool

This tool is used frequently to quickly navigate to a particular line and then either Forward or Backward incrementally.

The tool is activated from the View>Toolbars>Line Iterator Tool. The Line Iterator is a form of floating toolbar that can be moved around the screen or docked with the main Discover Viewer window.

The Line Iterator toolbar uses one of three modes:

- **Standard** mode navigates lines in the order they are stored in the survey database.
- **Spatial** mode reorders the line list spatially.
- **Sequential** mode is a more robust and useful option in complex documents that access multiple datasets.

The pull-down line list shows all lines with similar orientation to the one in the current graph display. The line azimuth is used to find lines of similar orientation so that tie lines and flight lines are not projected onto the one graph. The tolerance range for detecting a similar orientation can be changed to accommodate line divergence.
Selecting a line moves all graphs to the selected line or with their appropriate line offset. Moving lines by clicking the buttons of the Line Iterator toolbar, moves all lines in the plot forward or back in the iterator line list.

The sense of a display for a profile of data can be reversed (flipped), by using the Reverse Line Direction button. The display reversal applies to all profiles contained within a document (even if contained in different frames).

The operation of the Line Iterator is controlled by the properties available from the Line Iterator Properties button which will display the Property dialog.
5 Controlling the Display Window

The contents of the Display Window is primarily controlled with the Workspace Tree.

- Working with the Workspace Tree

This can incorporate one or more display types:

- Display Types

Which can incorporate one or more data types, with multiple data layers:

- Object Types

From the Workspace Tree you can:

- Hide and Show Objects
- Configure Axis
- Change Scale and Axis Exaggeration
- Change Lighting

Other display controls are available from the Main Menu and Toolbars:

- Display a Floating Colour Bar
- Change Background Colour
- Display a Sky Map

Working with the Workspace Tree

The **Workspace Tree** is the primary control for the Display Window. The Workspace Tree lists all objects shown in a display. These entities are listed as a hierarchy with various tree branches.
Each branch is subordinate to a higher branch, such that the properties of a higher branch overrule the same properties of a lower branch. To the left of each subordinate branch is a + or - control. These controls indicate lower levels exist for that branch. By clicking on these boxes you can expand or collapse the object contents.

To the right of each branch are several selectable controls:

**Select** – Enables objects in the selected dataset or feature database to be selected and interrogated (see Interrogating Objects).

**Browse** – Attribute information for a selectable datasets can be dynamically viewed in the Data Window. Objects types that are browsable include drillholes, lines, directional vectors and points. The Cursor Plane is automatically enabled in this mode and bonded to the Browsable dataset (see Bond tool on Cursor Plane Toolbar).

**Zoom Extents** – Zoom the 3D view to the extents of the selected dataset.

**Zoom All** – Zoom the 3D view to the extents of all data in the 3D Data Window.
Selecting a branch and clicking the right mouse button displays a shortcut menu that has available operations applicable to that object type.

**Display Types**

A Discover Viewer session may include a number of components in the Display window.

Sessions created with Discover 3D will have solely a 3D Map window, whilst sessions created with Discover PA may have a combination of any of the display types listed below, contained as Frames in one or more Plot windows.

<table>
<thead>
<tr>
<th>Display type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Profile</td>
<td>Provide a rich form of line data analysis that allows multiple lines to be visualised and analysed. The projection of adjacent lines onto a common base line allows finely detailed features to be tracked across lines. This style is well suited to multi-channel airborne EM, magnetic and gamma ray spectrometer data. The transverse graph is a vertical form of the profile that is well suited to plotting wireline log and drillhole geochemistry data.</td>
</tr>
</tbody>
</table>
Object Types

The types of objects that can be displayed in Discover Viewer are:

- The X, Y, and Z axes
- Feature database
- 3D block/voxel models
- Gridded surfaces
- 2D vector data

**Graphs**

- Scattergrams, Graphs and Decay Curves can be displayed as 2D and 3D variants, allowing powerful multi-channel analysis.

**2D Maps**

- A two-dimensional map may contain flight paths, images, grids, contours and other object types.

**3D Maps**

- The only view produced by Discover 3D, 3D displays can incorporate drillholes, voxel/block models, multiple grids, as well as many other object types.
Object type Description

- 3D vector data
- Geo-referenced images and drapes
- Drillhole traces and sample intervals
- Displacement or flow vectors
- Lines, polylines and polygons
- Points
- Flight Paths
- Grid Contour
- Section
- Section Grid
- Curve
- Stacked Profile

Hide and Show Objects

Each object branch in the **Workspace Tree** has a visibility check box. To turn off the visibility of an object branch in the display window clear the visibility box. Turning off the visibility for an object branch will also turn off the visibility of any sub-branches.
Configure Axis

In the Workspace Tree, right-click on the Axis branch, and select Properties. The Axis Properties dialog is displayed. You can also display the 3D Map Properties dialog from the Show 3D Properties button on the Main toolbar.

The Axis Properties dialog controls all aspects of the displayed axes. Manual and automatic options are available for:

- Axis origins (as related to axis locations) and styles.
- Axis extents and bounding box settings
- Axis tick display and intervals
- Axis title and tick labelling

To add a new axis layer, on the Display menu, click Axis. The Axis Properties dialog is displayed from which the new axis can be configured independently to the default axis.

You can also remove axis layers from the Workspace Tree.

Change Scale and Axis Exaggeration

In the Workspace Tree, right-click on the 3D Map branch, and under Properties, and select 3D Map. The 3D Map Properties dialog is displayed. You can also display the 3D Map Properties dialog from the Show 3D Properties button on the Main toolbar. Select the Scale tab.
The **Scale** tab of the **3D Map Properties** dialog allows the X, Y and Z axes along with the 3D objects to be scaled independently along each axis. This can be achieved by manually entering a scale factor or by adjusting the slider bar.

The **Datum scale correction** should be selected when using Latitude/Longitude datasets to equilibrate the X, Y & Z axis units. A datum scale correction is normally required with Latitude/Longitude datasets as the X and Y values are located in decimal degree units whist the Z values are located in metre units. This unit difference can make the dataset appear distorted. This can be disabled, allowing manually scaling via the Z axis control.

**Note**

The scaling factors will apply to all datasets within the 3D data window.

The **Projection** control displays the global projection of the 3D session. Any datasets that have a different projection are automatically reprojected into this projection.
Change Lighting

In the Workspace Tree, right-click on the 3D Map branch, and under Properties, and select 3D Map. The 3D Map Properties dialog is displayed. You can also display the 3D Map Properties dialog from the Show 3D Properties button on the Main toolbar. Select the Lighting tab.

![3D Map Properties Lighting Tab dialog](image)

The Lighting tab of the 3D Map Properties dialog controls the lighting displays for the 3D Display Window. Two light modes exist, Directional and Global Ambient.

Directional lighting enables a choice of three lighting modes. Directional light enables the casting of shadows and can give the 3D display the appearance of depth, and highlight variability in terrain.

- Ambient: Select a colour for the general light or illumination of objects displayed in the 3D Display Window. For example, if white is selected the objects in 3D will appear very bright and illuminated; if black is selected objects in 3D will appear dark with a low brightness level, independent of the light direction.
- **Diffuse**: Select a colour which will be used to cast shadow effects on undulating objects or topography. Generally, shades of grey produce the best effects. Diffuse light gives the appearance of a unidirectional light source.

- **Specular**: Select a colour to be used for highlights in the 3D Display Window. Highlights are objects or surface facets perpendicular to the lighting direction.

The Light Position Angles control contains a dynamic ellipse to define the Horizontal and Vertical positions of the directional light. The light source direction can be modified by pressing and holding down the left mouse cursor over the red cross on the ellipse and moving to an appropriate position; or by manually adjusting the Horizontal and Vertical values.

The Fixed direction option will fix the light source direction as specified on the ellipse independent of the position of the 3D Display Window axes. If the option is not selected the light position is defined by the axes position in the 3D Display Window.

Global Ambient lighting enables one lighting mode, and refers to the general light conditions. Global ambient light doesn't allow the generation of shadows or highlights.

- **Ambient**: Select a colour for the general light or illumination of objects displayed in the 3D Display Window. For example if white is selected the objects in 3D will appear very bright and illuminated; if black is selected objects in 3D will appear dark with a low brightness level.

**Display a Floating Colour Bar**

The Floating Colour Bar button enables a Colour Scale to be created for any open drillhole project, grid surface or voxel model. This makes it easy for the user to see the corresponding value for a particular grid colour (eg. DEM or magnetic susceptibility) or the corresponding lithology for a particular colour pattern in a drillhole series. Floating Colour Bars can be viewed in both and are particularly useful in 3D hard copy or digital Output.

**Display Floating Colour Bar** - Add a Floating Colour Bar or data legend which can be linked to surface, voxel or drillhole data types.

Activating the Floating Colour Bar button changes the cursor to the colour bar creation mode. This mode enables the position and size/shape of the Floating Colour Bar to be determined on the screen.
To modify the Floating Colour Bar single mouse click on the blue bounding box with the **Select/Navigate** tool. Click on a bounding box corner to resize the box or click and drag on a side wall of the bounding box to move the Floating Colour Bar to a new location.

Once a Floating Colour Bar is created a corresponding branch is added to the **Workspace Tree**, with a Colour Legend sub-branch. A Floating Colour Bar can be deleted by highlighting this branch, and pressing the keyboard **Delete** key.

The **Connection** tab of the **Colour Legend Properties** dialog enables the selection of the source dataset, for example a drillhole project, voxel model or grid surface. Only one bolded dataset can be selected for each Floating Colour Bar. The remaining dialog tabs contain controls to apply and modify the **Stretch** (eg linear or non-linear), **Appearance**, **Title**, **Divisions** and **Ticks** of the colour axis.

The **Title** tab of the **Colour Legend Properties** dialog enables a Title to be added (via a user text string) and positioned for the entire Floating Colour Bar (note axis specific Title option in the **Colour Legend Properties** dialog).

![Example of a Floating Colour Bar linked to a drillhole project colour modulated by geology. The displayed colour legend contains an entry for each rock type.](image)
Example of a Floating Colour Bar showing elevation values linked to a DEM grid surface.

Change Background Colour

- Click the Background Colour button on the Main toolbar and select a colour from the palette.

You can also change the background colour from the Appearance tab on the 3D Map Properties dialog (see Borders, Background, and Margins).

Display a Sky Map

The Sky Map option (on the Insert menu) allows you to add a photo-realistic sky view backdrop to your 3D environment. This can be particularly valuable for producing impressive image/video output.

Selecting the Sky Map option from the Insert menu will prompt the user to select from the available sky map images (located in the C:\Program Files\Encom\Common\SKYMAP directory). Each image can be previewed within the selection dialog. Press OK to display the selected image. A Sky Map branch will be added to the Workspace Tree: its visibility can be toggled, and it can be either reordered (e.g. multiple Sky Maps listed) or deleted by accessing the right-click pop-up menu.
Example Sky Map to select for display.

Example of SkyMap background in complex 3D cityscape view.
6 Interrogating Objects

You can interrogate objects displayed in the Display Window by interactively measuring spatial relationships, displaying the attributes of 3D objects and features, and dynamically clipping the view space.

- **Distance and Bearing Tool**
- **Interrogating Objects**
- **Interrogating Features**

Other useful tools are available from the *Tools Menu*.

**Distance and Bearing Tool**

On the Main toolbar, click the **Distance/Bearing Measuring** tool. The tool measures distance, bearing, inclination and total distance on the Cursor plane. If not already displayed, the Cursor Plane is also displayed.

- To measure between two or more points, click each point on the Cursor Plane. The cumulative measurement is displayed.
- To measure along a continuous path, click-and-drag the cursor to trace the path. The cumulative measurement is displayed.
- Press S on the keyboard to turn on snapping.

All measurements are made on the Cursor plane. See *3D Cursor Plane* for information about how to position and orientate the Cursor Plane.

**Interrogating Objects**

You can interactively display data from the following object types: drillholes, lines, directional vectors and points.

1. In the Workspace Tree, make the object selectable.

2. In the Workspace Tree, select the Browse option for the selected object. If not already displayed, the Data Window is opened and the Cursor Plane is displayed. The cursor plane is automatically bonded to the object.
3. Move the cursor over the object in the Display Window. The attributes are displayed in the Data Window.

Interrogating objects in 3D

Interrogating Features

You can interactively display information from features in the Display Window.

1. In the Workspace Tree, make the Feature database selectable.

2. Click the **Feature Data Window** button to open the Feature Data window.

3. Move the cursor over the feature in the Display Window. The attributes are displayed in the Feature Data Window. Alternatively, select an object in the Feature Data Window to locate it in the Display Window.

Clipping

The Cursor plane can be used to hide or obscure object data. This can be useful in complex datasets where a mass of drillholes obscures the data of interest. Alternatively, only a user-specified envelope or slice of data about the plane can be displayed. For more information, see **3D Cursor Plane**.
7 Output and Printing

• Page Layout Mode
• Add a Title
• Borders, Background, and Margins
• Capturing the View as an Image
• Printing

Page Layout Mode

The Page Layout view of the current 3D environment.

Within Page Layout mode, the full set of buttons for Navigation are available to precisely position the view within the page frame. Additionally, Discover Viewer provides a number of controls on the Zoom Controls Toolbar specific to this view mode:
The **Zoom In** and **Zoom Out** controls allow adjustment of the overall zoom ratio of the page display. The **Pan** button allows you to pan around the page view, useful when zoomed into larger page sizes (e.g. A1).

The **Fit to Page** button is only available in Page Layout view, and automatically resizes the page to fit to the extents of the view.

The **3D View Manager** allows the user to save custom views within the 3D window.

The **Orthographic View** mode functions in Page Layout mode (see 3D Display Modes), allowing hardcopy production for technical evaluations (i.e. without the distance distortion of the default perspective view).

### Customizing the Page Layout

The Page Layout view can be fully customized with titles, borders, margins, etc from the 3D Map Properties dialog in the Workspace Tree. Options include:

- **Title** – the Title tab allows the addition of a title string in the Coded Title String area with a selected Font. The Horiz and Vert options control the Title Position with respect to the 3D window display. The Anchor options locate the title locally (this can be fine tuned using the Add Offset controls).

- **Border** – the Appearance tab allows Inner and Outer borders to be displayed, with colour, thickness and line style options.

- **Background** – Data Area and Border (the area between the inner and outer borders) colours can be specified in the Appearance tab. The Data Area control is the same control as the Background Colour button on the Main Toolbar.

- **Minimum Plot Margins** – these can be set as millimeters recessed from the Outer Border position.

The position and size of the 3D view frame inside the page layout can be modified by enabling the Select button.

The position and size of the 3D view frame inside the page layout can be modified whilst in **Select** mode. Click on a border of the 3D view frame (the 4 corner points should display square nodes), and drag either a corner point (to resize) or an edge (to move).
Add a Title

1. Click the **Show 3D Properties** button on the Main toolbar and select **3D Map**.

2. On the **3D Map Properties** dialog, select the **Title** tab.

![3D Map Properties Title Tab dialog](image)

The **Title** tab of the **3D Map Properties** dialog controls the placement, content and font of the map title displayed within the **Page Layout** mode. The 3D window mode is toggled from the **View>Normal** or **View>Page Layout** menus. This can be particularly useful when generating titled images from **File>Save View As** or when printing hardcopies.

The **Coded Title String** provides variable title string syntax which automatically inserts values from the 3D dataset with a selected **Font**. Select the variable from the list and press the **Add** button to add the syntax to the title. Alternatively, a title can be manually entered into the title box.

The **Horiz** and **Vert** options control the Title Position with respect to the 3D window display. The **Anchor** options locate the title locally (this can be fine tuned using the **Add Offset** controls).
Borders, Background, and Margins

1. Click the **Show 3D Properties** button on the Main toolbar and select **3D Map**.

2. On the **3D Map Properties** dialog, select the **Appearance** tab.

The **Appearance** tab of the **3D Map Properties** dialog controls the border styles, colours and margins for 3D displays in the **Page Layout** mode along with numerous other general appearance settings.

Options for toggling the background colour of the 3D **Display Window** are available, along with the display option for a 3D bounding data box. The bounding box displays a minimum bounding rectangle around the 3D dataset.

To improve distortions and artefacts in 3D object rendering, enable the anti-aliasing option. The **Advanced** button provides default colour options for vector objects in 3D.
Capturing the View as an Image

File>Save View As

This allows the current view to be saved as an image at a user-specified resolution. A range of output image formats are available, including BMP, JPG, PNG, TIF, and EMF. This image is not georeferenced i.e. it is essentially a screenshot. These images could be used in a Word or PowerPoint document.

Consider the Orthographic View mode (see 3D Display Modes) for outputting 3D image for technical evaluations (i.e. without the distance distortion of the default perspective view).
Printing

Every aspect of the current view can be printed directly to a printer or plotter using the File>Print menu option, with printer and page size options configured via the standard File>Page Setup menu option.

![Print dialog](Image)

**Printer and Rasterize options**

**Note**

Discover Viewer can use standard Windows drivers directly for printing **OR** it can use a rasterizing option to speed up and produce higher quality printed output. The rasterize option is included on the Print dialog and is recommended for routine use in printing. It is recommended that a rasterizing level of between 150 and 200 dpi is optimal for speed and quality.

However, professional looking results are better achieved when Discover Viewer is in **Page Layout Mode**. This allows the actual output display for the currently set page size and orientation to be previewed and modified prior to printing.
Default and Offline Printer Configuration

The *Page Setup Tab* of the *Tools>Options* dialog in the Display Window allows the default printer and page size/orientation to be configured. It also allows a default offline page size to be set.
Customizing Discover Viewer

In this section:

- Customizing Interface Settings
- Customizing Toolbars
- Assigning Custom Keyboard Shortcuts

Customizing Interface Settings

The Tools menu in the Discover Viewer window provides access to the Options dialog, which enables the control of numerous settings.

Options that can be specified include:

- Paths for data and templates.
- Default page size (in the absence of an installed printer).
• Preferred view options.
• Specific file locations.
• Default printer page size and orientation.
• Auto-reloading of modified files in use.

For more information, see:

• File Tab
• Size Tab
• View Tab
• File Locations Tab
• Page Setup Tab
• Full Screen Tab

File Tab

Record accessed directories enables or disables the last used file paths when using open or save dialogs. These include the general Global directory and session open/save, as well as survey database (drillholes) and grid files.

Monitor data files for changes and reload adds support for automatic update/refresh when data files are edited.

The Autosave session setting defines how frequently the recoverable autosaved session file (File>Restore Autosave Session) is updated.

Show file loading report after session loading enables a list of files automatically found or skipped after opening a session.

Use relative paths to resolve files in sessions improves the automatic resolving of moved or missing files when opening session files.
Size Tab

**Raster grid size** limits the largest surface grid that will be loaded by default in a surface or image branch.

**Texture size** defines the resolution or raster images such as JPG, bitmaps or ECW files which are usually loaded in an Image branch. Generally only up to 4096x4096 is supported by graphics cards. Image files larger than 4096x4096 pixel resolution will be decimated to this size.
Support for the 3DConnexion SpaceNavigator™ device is enabled in this dialog: see *Using the 3DConnexion SpaceNavigator™* for use of this device in navigating the 3D environment.

**Show navigation pads** enables the navigation buttons that are embedded in the 3D window when 3D navigation cursor mode is selected.

**Show frame rate** displays frames per second at the top left of the 3D window.

**Show properties of new objects on creation** automatically opens the properties of a branch when a new branch is added/opened in the 3D Map.

The position of the XYZ indicator is also controlled on this tab.
File Locations Tab

Preferred datasets, sessions, surface grids, colour tables and patterns can be saved in specified default locations. These locations usually are defaulted but these values can be overridden by selecting the item to be specified from the displayed list and then using the **Modify** button.
Specify the default locations of various files

The option to **Use Global Directory** is enabled by default. This setting is used for accessing all file types from a single source folder. The folder is defined by selecting the Global Directory item and clicking the **Modify** button to set the Global Directory location.

**Page Setup Tab**

The **Page Setup** tab of the **Options** dialog provides support for default printers when Discover Viewer is connected to or remote from printers or plotters. This default sets the automatically displayed page when a **Page Layout** display is presented. The layout may alter depending on whether Discover Viewer can find the specified drivers for the defined printer/plotter. If these Windows drivers cannot be found on the machine, the Windows default printer settings are used.

To modify the printer default setting for Online printers, select the **Page Setup** button.
Full Screen Tab

This dialog enables you to manually configure the Display settings used when Discover Viewer is in Full Screen mode. (With the Select/Navigate tool selected, right-mouse click in the 3D window and select the Create Fullscreen View option. Click Esc to cancel out of this view mode).

Options available include resolution, colour depth and display frequency of the fullscreen window.

This can be used to improve performance when viewing the 3D window full screen on large monitors or high resolution projectors.

Customizing Toolbars

- Adding and Removing Tools
- Restoring Toolbar Settings
- Toolbar Button Size
• Show and Hide Tool Labels
• Creating New Toolbars
• Other Customizations

Adding and Removing Tools

Existing tools on the toolbars can be quickly displayed or hidden by clicking on the dropdown arrow on the selected toolbar. Select Add or Remove Buttons and the appropriate toolbar to customize. And then select or deselect the tool to display or hide.

The tools available on toolbars can also be customized to suit the user requirements. To open the Customize dialog either right mouse click on the Main menu bar and select the Customize option or from a toolbar navigate to the dropdown arrow on the selected toolbar and select Add or Remove Buttons followed by the Customize option.

![Add or Remove Buttons dropdown menu]

From the Customize dialog navigate to the Commands tab, select a tool, from the Commands list drop and drag a select command into an existing toolbar. Next time Discover Viewer is started, the customized toolbar will be displayed.

Restoring Toolbar Settings

To restore a toolbar to factory settings, click on the dropdown arrow on the selected toolbar. Select Add or Remove Buttons and the appropriate toolbar to customize And then select or Reset Toolbar.

You can also reset one or all toolbars by selecting the Customize option on any toolbar dropdown menu, and selecting the Toolbars tab.

Toolbar Button Size

To display toolbar icons in a larger style, navigate to the Customize dialog by right mouse clicking on the Main menu bar. On the Options tab check the Large Icons option.
Show and Hide Tool Labels

To hide and show tool labels, navigate to the Customize dialog by right mouse clicking on the Main menu bar. Check the Show text labels option on the Toolbars tab of the Customize dialog, the selected toolbar will display the tool label as well as the icon.

Creating New Toolbars

As well as customizing existing toolbars up to ten user-defined toolbars can be created. To create a toolbar navigate to the Toolbars tab on the Customize dialog and press the New button. Type in an appropriate name for the toolbar. Using the procedure for customizing individual toolbars navigate to the Commands tab, select a tool, from the Commands list drop and drag a select command into the new toolbar.

Other Customizations

Located on the Menu tab of the Customize dialog are options for menu list effects and shadows.

Located on the Options tab of the Customize dialog are options for displaying screen tips, shortcut keys and enlarging the toolbar icons.

Assigning Custom Keyboard Shortcuts

Some commands already contain built-in shortcuts, such as Print (CTRL+P). Additional shortcuts can also be set up for these menu commands using the Keyboard tab in the Customize dialog.

To add a keyboard shortcut to Discover Viewer open the Customize dialog and select the Keyboard tab. Select a Category from the pull-down list and select a Command from the list displayed. Click the mouse cursor in the Press New Shortcut Key box and select the keyboard shortcut (use CTRL and SHIFT keys if desired). Click the Assign button to complete the shortcut creation.

To remove a keyboard shortcut, select a command click the Remove button. To remove all custom shortcuts click Reset All.

To display the custom shortcut in the menu system navigate to the Customize dialog and select the Options tab, check the Show shortcut keys in Screen Tips option.
Appendices

A 3D Cursor Keyboard Shortcuts
A 3D Cursor Keyboard Shortcuts

Using this Card
This card can be used as a quick reference for the 3D cursor shortcut keys. These shortcuts can be used in conjunction with the standard menu items and toolbar icons.

Key
Shortcut keys apply once functions have been activated.

Navigation
Snapping
- Toggles snapping on and off

Cursor Plane Display
- Toggles cursor plane display
- Centres the view at the current cursor position
- Extends the focus box to encompass the current 3D cursor location (does not move the cursor plane)
- Switches the view orientation between standard view planes: XY, YZ, and XZ

Cursor Plane Position and Orientation
- Switches the cursor plane orientation between standard view planes: XY, YZ, and XZ
- Orientates the cursor plane parallel to XY plane
- Orientates the cursor plane parallel to YZ plane
- Orientates the cursor plane parallel to XZ plane
- Moves the cursor plane towards or away from the viewpoint
- Changes the cursor plane inclination/dip
- Changes the cursor plane azimuth/bearing
- Centres the cursor plane without changing its orientation

Note: The position/orientation of the cursor plane changes at a slower/faster rate if the Shift/Spacebar keys are pressed.

Bending Cursor Plane to Images
- Bends or unbinds the cursor plane to the selected image
- Numeric keypad iterates through all selected images

Mouse Symbology
- Left button click
- Right button click
- Dragging mouse with the left button pressed down
- Dragging mouse with the right button pressed down
- Dragging mouse with the left and right buttons pressed down

Navigation
- Rotates the view
- Zooms in and out
- Moves the viewing centroid horizontally in the XY plane
- Moves the viewing centroid vertically and parallel to the screen plane
- Plans the view from a fixed 'look from' position

Feature Editing
- Cursor Plane Position and Orientation
- Snapping
- Bonding Cursor Plane to Images
- Cursor Plane Display
- Navigation
Index

Numerics
3D cursor keyboard shortcuts 81
3D Map Properties 62, 63, 64
3D Navigation mode 16
3D Stereo 10
3D stereo visualization 36
3D View Manager 12, 16, 62
3DConnexion SpaceNavigator™ 33

A
About Discover Viewer 14
Actual Size 10
Appearance 10, 64
Arrange Icons 13
Auto-hide windows 20
Axis 11

B
Background 62
Bond 17
Border 62
Browse 48, 59

C
Calculator 12
Cancel button 25
Cascade 13
Change View Direction 16
Clipping 17, 60
Close All 8
Coded Title String 63
Cursor Plane
  Lock 17
  Orientation 17
  Properties 18
  Show 17, 18
  Shrink, enlarge and fit 18
  Cursor Plane Properties 39, 40, 41
  Cursor Plane Toolbar 17

D
Data Fit 17
Data Manager 10
Data Pan 17
Data Window 7, 11
Data Zoom 17
Data Zoom To Extents 29
default locations 73
Default page size 69
Default printer page size 70
Display Menu 6, 11
Display Properties 15
Display Window 6
Distance/Bearing Measuring 59
Docking and undocking 19

E
Exit 8

F
Feature Data Window 6
Feature Spreadsheet 11
File locations 70
File Menu 6, 7
Fit to Page 9, 16, 62
Floating Colour Bar 11
forward line navigation 46
Full Screen 10
Fullscreen mode
  3D view 35

G
Grid Flipper 12
H
Help Menu 6
Help Topics 13
Hide and show objects 21

I
Interface
  Customizing 19
Interrogate Features 60
Interrogate Objects 59

K
keyboard shortcut 81

L
Line Iterator Properties 46
Line Iterator toolbar 46

M
Main Window 5
Minimum Plot Margins 62

N
New Window 13
Normal mode 9
Normal View mode 35
NotePad 12

O
Online printers 74
Open Session 8
Options 12, 67, 69
Options tab 72
Orthographic View mode 16, 62, 65

P
Page Layout display 74
Page Layout mode 10, 35
Page Setup 8, 66
Page Setup tab 74
Pan 62
panning
  of data 28
panning of data 28
Perpendicular 18
Perspective View mode 16
Preferred view options 70
Print 8, 66
Print Setup 8
Printing 66
profile scrolls 28
Projection 49
properties
  of Line Iterator 46

R
Rasterize 66
Reset Arrangement 10
Reset View 16
Restore Arrangement 10
Reverse Line Direction 46
roaming
  data 28

S
Save Arrangement 10
Save View As 8, 65
scroll wheel 28
scrolling of data 28
Select 48
Select/Navigate mode 15, 40
selecting a line 46
Session file list 8
Show Cursor Plane 39
Sky Map 11
smooth scrolling of a profile 28
SpaceNavigator
  controls 33
device 33
Split 13
Status Bar 6, 11
Index

T
Tile 13
Title 62, 63
Toolbar
  Cursor Plane 17
  Main 14
  Zoom Controls 15
Toolbars 6, 14
  Customizing 20
  Hide and show 10
  Show and hide 19
Tools Menu 6, 12
Types of objects 50

U
Use Global Directory 74
User Guide 13

V
View Menu 6, 9
View modes
  Full screen 35
  Normal 35
  Orthographic 16
  Page Layout 35
  Perspective 16
Visibility 21

W
window linking 29
Window Menu 6
Windows
  Customizing 20
Workspace Tree 10, 21, 47

Z
Zoom 16, 62
Zoom All 48
Zoom Extents 48
Zoom Page in Place 15